Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I installed mongrel cluster and nginx module for it on to my virtual machine. The working environment is

ruby 1.9.2
rails 3.0.6
rubygems 1.7.2
mongrel_cluster 1.0.5
mongrel 1.2

When I start the mongrel cluster, it throws me the following error. The application is off line Please suggest me some solution. I have tried lot many googled solutions and none of them fixed the issue. Any kind of help is appreciated.

*starting port 8011
NOTE: Gem::SourceIndex.from_installed_gems is deprecated with no replacement. It will be removed on or after 2011-10-01.
Gem::SourceIndex.from_installed_gems called from /usr/local/lib/ruby/gems/1.9.1/gems/gem_plugin-0.2.3/lib/gem_plugin.rb:109
.
NOTE: from_installed_gems(arg) is deprecated. From /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/deprecate.rb:62:in `block (2 levels) in deprecate'
NOTE: Gem::SourceIndex.from_gems_in is deprecated with no replacement. It will be removed on or after 2011-10-01.
Gem::SourceIndex.from_gems_in called from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/source_index.rb:50
.
** !!! PID file tmp/pids/mongrel.8011.pid already exists.  Mongrel could be running already.  Check your log/mongrel.8011.log for errors.
** !!! Exiting with error.  You must stop mongrel and clear the .pid before I'll attempt a start.*

EDIT:

Thank you @dioms and @Hmallett. I updated the gems and deleted the already existing pid files from tmp/pids and restarted d cluster. It gave me d error

NOTE: Gem::SourceIndex.from_installed_gems is deprecated with no replacement. It will be removed on or after 2011-10-01.
Gem::SourceIndex.from_installed_gems called from /usr/local/lib/ruby/gems/1.9.1/gems/gem_plugin-0.2.3/lib/gem_plugin.rb:109
.
NOTE: from_installed_gems(arg) is deprecated. From /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/deprecate.rb:62:in `block (2 levels) in deprecate'
NOTE: Gem::SourceIndex.from_gems_in is deprecated with no replacement. It will be removed on or after 2011-10-01.
Gem::SourceIndex.from_gems_in called from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/source_index.rb:50
.
starting port 8009
NOTE: Gem::SourceIndex.from_installed_gems is deprecated with no replacement. It will be removed on or after 2011-10-01.
Gem::SourceIndex.from_installed_gems called from /usr/local/lib/ruby/gems/1.9.1/gems/gem_plugin-0.2.3/lib/gem_plugin.rb:109

Please suggest me some solution to it. I am a newbie to the server installations and I am not sure what exactly to include in the configuration script.

share|improve this question

2 Answers 2

Looks like some of your gems are deprecated

Try this to update them

gem update && gem update --system

share|improve this answer

Does tmp/pids/mongrel.8011.pid exist?

Are you sure a mongrel is not already running and listening on port 8011?

If so, rm tmp/pids/mogrel.8011.pid and try restarting.

The deprecated gem warning is just a warning, the last two lines are the clue why it doesn't start.

Also, it looks like you're running Ruby 1.9.1, but I think rails 3 needs 1.9.2 if you want to use ruby 1.9.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.