Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been knocking my head out for a while on this one and have read many tutorials, but I just can't get this to work. Ajaxterm, is a webbased SSH client; once installed apt-get install ajaxterm and then enabling it with /etc/init.d/ajaxterm start I should be able to access the SSH terminal with http://mywebsite:8022/

But doing so only gives me a "Page not found", any suggestions?

My actual VPS is: http://173.244.205.160


My sources: https://secure.kitserve.org.uk/content/setting-ajaxterm-Ubuntu-and-Debian-powerpc

http://wiki.kartbuilding.net/index.php/ajaxterm

share|improve this question
    
There's something about the concept of ajaxterm that scares me. –  Tom O'Connor Apr 19 '11 at 10:10

1 Answer 1

up vote 1 down vote accepted

By default Ajaxterm only listens on localhost:8022 so it won't be listening on your VPS's IP address:8022. You have to install and configure Apache if you want to access it on an address other than localhost:8022. Fortunately the second link you provide contains instructions for doing just that.

EDIT:

I don't know Debian - hopefully Ubuntu will be close enough.

  • Create a vhost file e.g. ajaxterm in /etc/apache2/sites-available and add the configuration from the Ajaxterm wiki.

  • Enable the vhost with a2ensite ajaxterm

share|improve this answer
    
thanks for clearing that up. On the page linked, it says "Put the following in an Apache vhost file" where can I locate this vhost file? –  Kevin Duke Apr 19 '11 at 9:11
1  
@KevinDuke: See my edit. –  Iain Apr 19 '11 at 9:42
    
thanks lian -- I really appreciate this, some hold up though, pastebin.com/B2DFQLyB it's saying I have an Invalid command 'SSLEngine' in apache2? however I haven't touched that file. Here is my apache2.conf pastebin.com/cMq12nZr –  Kevin Duke Apr 20 '11 at 0:06
    
@KevinDuke: You may need to put NameVirtualHost *:443 in your apache2.conf file –  Iain Apr 20 '11 at 5:39
    
hmm I added that in a random location and I get the same error. sorry I'm so stupid, any suggestions? –  Kevin Duke Apr 24 '11 at 7:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.