Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm quite a noob at configuring servers. Anyway, I'm running CentOS 5 and I've been meaning to install the php-xml package for my PHP 5.2.17. This server runs proprietary software which requires PHP 5.2 to be installed and not 5.3.

Currently, I was using the atomic repo. But when i do a yum install php-xml it want to update all php packages to bleeding edge version of 5.3.6. I don't want that - I want to leave it as it is and install php-xml 5.2.17.

So I've downloaded the php-xml package by itself and tried to install it when it threw an error saying:

Examining php-xml-5.2.17-1.x86_64.rpm: php-xml-5.2.17-1.x86_64
Marking php-xml-5.2.17-1.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package php-xml.x86_64 0:5.2.17-1 set to be updated
--> Processing Dependency: php-common = 5.2.17-1 for package: php-xml
--> Processing Dependency: libexslt.so.0()(64bit) for package: php-xml
--> Processing Dependency: libxslt.so.1()(64bit) for package: php-xml
--> Running transaction check
---> Package libxslt.x86_64 0:1.1.17-2.el5_2.2 set to be updated
---> Package php-xml.x86_64 0:5.2.17-1 set to be updated
--> Processing Dependency: php-common = 5.2.17-1 for package: php-xml
--> Finished Dependency Resolution
php-xml-5.2.17-1.x86_64 from /php-xml-5.2.17-1.x86_64 has depsolving problems
--> Missing Dependency: php-common = 5.2.17-1 is needed by package php-xml-5.2.17-1.x86_64 (/php-xml-5.2.17-1.x86_64)
Error: Missing Dependency: php-common = 5.2.17-1 is needed by package php-xml-5.2.17-1.x86_64 (/php-xml-5.2.17-1.x86_64)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                    package-cleanup --dupes
                    rpm -Va --nofiles --nodigest

Even though I checked and I do have php-common 5.2.17-1 installed like the rest of PHP packages.

So I figure that I need a repository which delivers 5.2.17 php packages, is that right? Couldn't find it by myself.

Thank you for any info on what should I do.

share|improve this question

1 Answer 1

pear install XML_Parser # try to install it via pear not rpm
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.