Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Purpose: boot an Ubuntu 10.10 LiveCD, and run a pppoe server on it...
I thought it's just like this:
1) I create a user
2) I run "pppd require-pap"
...but noooo

why? I'm trying to run pppd but it gives the:
pppd: The remote system is required to authenticate itself
pppd: but I couldn't fin any suitable secret (password) for it to use to do so.

Can anyone post it in a few lines how to do it?

I just need a pppd server using only PAP [i don't really need that users can log in, etc.], because i just want that that the clients try to log in with PAP, so I can tcpdump the username/passwords, because we don't have them.

Thank you!! :\ it's getting important..

share|improve this question

1 Answer 1

You need to do a lot more then just configure pppd options; you also need the PPPoE server to handle the ethernet stuff.

#!/bin/bash

killall pppoe-server

MAX=250
INTERFACE=eth0
BASE=10.10.100.1 # clients get an IP starting here.
MYIP=10.10.10.252 # set to your eth0 IP address.
/usr/sbin/pppoe-server -T 60 -I $INTERFACE -N $MAX -C CANADA -S PPPoE7 -L $MYIP -R $BASE

This is basically the script we use with our test DSLAM and PPPoE stuff in our office. We are running on Debian Lenny so it should all work similiarly on Ubuntu. You also may need an /etc/ppp/pppoe-server-options file with just the following in it:

login

You might also need to at least add the username (with a bogus password) in /etc/ppp/pap-secrets?

The man page for pppd says to use the following in the options file to disable CHAP:

disable-chap
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.