Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to install under RVM the Ruby Enterpise (REE) under debian

My debian is squeeze (uname -r)

2.6.18-194.26.1.el5.028stab070.14xen

i did try to install ree but it complains that it is missing libssl-dev and libreadline5-dev. I did update my lenny to squeeze, but i didn't update the kernel, since its a production server.

The operational system is already updated and upgraded

sources.list:

deb http://ftp.de.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.de.debian.org/debian/ squeeze main contrib non-free
deb http://security.debian.org/ squeeze/updates main 
deb-src http://security.debian.org/ squeeze/updates main

I did try to install it using the following command:

apt-get install libssl-dev libreadline5-dev

But unfortunately i'm getting the following problems:

The following packages have unmet dependencies:
  libreadline5-dev: Depends: libncurses5-dev but it is not going to be installed
  libssl-dev: Depends: libssl0.9.8 (= 0.9.8o-4squeeze1) but 0.9.8o-6 is to be installed
E: Broken packages

I was thinking to reinstall those packages and install again, but it has too many dependencies, and it is a production server, that i would like to know if there is any other way to fix it. Or at least to double check if it is necessary to reinstall both :-/

share|improve this question
    
Are you sure that system is up-to-date? 2.6.18 is a very old kernel, squeeze ships with 2.3.32. What sources do you have (/etc/apt/sources.list, /etc/apt/sources.list.d/*)? libssl0.9.8 0.9.8o-6 doesn't exist in squeeze, you probably have some non-official sources as well. –  Gilles Apr 19 '11 at 23:33
    
I wasn't even aware that 2.6.18 would run on squeeze due to the new version of udev. –  Arrowmaster Apr 20 '11 at 1:51

2 Answers 2

up vote 1 down vote accepted

There seems to be no 0.9.8o-6 for Ssqueeze (changelog), so I'd just download to 0.9.8o-4squeeze13 (higest security update for Squeeze).

aptitude update && aptitude install libssl-dev=0.9.8o-4squeeze13 libssl0.9.8=0.9.8o-4squeeze13 libncurses5-dev libreadline5-dev -t squeeze.

share|improve this answer

You might to specify from which distribution to install the dependencies; apt-get install -t stable libssl-dev or -t testing might help.

I don't have enough information to go on; try showing what happens for cat /etc/apt/sources.list.d/* and for cat /etc/apt/apt.conf.d/*

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.