Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm installing VMware Server 2.0 on an Ubuntu 9.04 system. I have an Ubuntu 9.04 guest with Bridged network interface configured.

When I try to get an address during installation, the guest fails to contact the DHCP server. NAT and Host-only networking both work fine, however.

share|improve this question

3 Answers 3

up vote 3 down vote accepted

Answering my own question, as the information is located in two places and not easily searchable, hopefully this helps someone else.

The problem is that the VSOCK module isn't getting compiled, despite gcc, binutils and the kernel source packages all being present.

ii  binutils                                  2.19.1-0ubuntu3                    The GNU assembler, linker and binary utiliti
ii  gcc                                       4:4.3.3-1ubuntu1                   The GNU C compiler
ii  linux-headers-2.6.28-11                   2.6.28-11.42                       Header files related to Linux kernel version
ii  linux-headers-2.6.28-11-server            2.6.28-11.42                       Linux kernel headers for version 2.6.28 on x
ii  linux-image-2.6.28-11-server              2.6.28-11.42                       Linux kernel image for version 2.6.28 on x86
ii  linux-source-2.6.28                       2.6.28-11.42                       Linux kernel source for version 2.6.28 with

There is actually a bug filed on Launchpad about this issue, and a user submitted a patch to a similar query on Ubuntu Forums. Patching the vmware-config.pl as described worked for me. Here's the patch:

--- /usr/bin/vmware-config.pl.orig  2008-11-28 12:06:35.641054086 +0100
+++ /usr/bin/vmware-config.pl   2008-11-28 12:30:38.593304082 +0100
@@ -4121,6 +4121,11 @@
     return 'no';
   }

+  if ($name eq 'vsock') {
+    print wrap("VMWare config patch VSOCK!\n");
+    system(shell_string($gHelper{'mv'}) . ' -vi ' . shell_string($build_dir . '/../Module.symvers') . ' ' . shell_string($build_dir . '/vsock-only/' ));
+  }
+
   print wrap('Building the ' . $name . ' module.' . "\n\n", 0);
   if (system(shell_string($gHelper{'make'}) . ' -C '
              . shell_string($build_dir . '/' . $name . '-only')
@@ -4143,6 +4148,10 @@
     if (try_module($name, $build_dir . '/' . $name . '.o', 0, 1)) {
       print wrap('The ' . $name . ' module loads perfectly into the running kernel.'
                  . "\n\n", 0);
+      if ($name eq 'vmci') {
+   print wrap("VMWare config patch VMCI!\n");
+   system(shell_string($gHelper{'cp'}) . ' -vi ' . shell_string($build_dir.'/vmci-only/Module.symvers') . ' ' . shell_string($build_dir . '/../'));
+      } 
       remove_tmp_dir($build_dir);
       return 'yes';
     }
share|improve this answer

Did you actually get the bridged networking working? I just installed 2.0.1 on jaunty (2.6.28-11) and it doesn't appear to be working.

Help!

share|improve this answer
    
Follow the link to the bug on Launchpad and patch the vmware-config.pl script as described. I'll embellish my answer with the patch. –  jtimberman Jul 6 '09 at 2:50

I guess my question was more regarding 2.0.1, I tried the patch but it bridged networking still doesnt appear to be working. What would be a good test? I just create a VM with a ubuntu server 9.04 iso and see if it can pull an ip from DHCP... when it cant I think that bridged networking is not working.

Should I download server 2.0.0 and try this?

share|improve this answer
    
I'm using VMware server 2.0.1, Build 156745. –  jtimberman Jul 6 '09 at 18:36
    
Maybe I am testing it wrong... It would be really great to get some help! I have seen issues where people dont have settings in their host correct for the bridged networking to work. –  storrgie Jul 6 '09 at 18:37
    
I am in the #vmware channel on irc.ubuntu.net, trying to get some help from them... Some people say it works no problem out of box... –  storrgie Jul 6 '09 at 18:44
    
Doing a fresh install of 9.04, hoping this will work. –  storrgie Jul 6 '09 at 19:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.