Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I forgot to put node command in site.pp, something like this:

class emacs {
    package {
emacs:
        ensure => installed
    }
}

node default {
        include emacs
}

Original question:

I installed puppetd and puppetmaster on my workstation. I'm running Fedora14, puppetd, puppetmaster version 0.25.5. When I run puppetmaster and puppet I get this in /var/log/messages:

Apr 20 08:51:31 localhost puppetmasterd[4734]: Reopening log files
Apr 20 08:51:31 localhost puppetmasterd[4734]: Starting Puppet server version 0.25.5
Apr 20 08:51:43 localhost puppetd[4768]: Reopening log files
Apr 20 08:51:43 localhost puppetd[4768]: Starting Puppet client version 0.25.5
Apr 20 08:51:44 localhost puppetmasterd[4734]: Compiled catalog for localhost.localdomain in 0.00 seconds
Apr 20 08:51:44 localhost puppetd[4768]: Finished catalog run in 0.09 seconds

My /etc/puppet/manifests/site.pp is like this:

class emacs {
    package {
emacs:
        ensure => installed
    }
}

class mc {
    package {
mc:
        ensure => purged
    }
}

I put just simple configuration, just to see if this is working.

/etc/puppet/puppet.conf is:

[main]
    logdir = /var/log/puppet
    rundir = /var/run/puppet
    ssldir = $vardir/ssl
[puppetd]
    classfile = $vardir/classes.txt
    localconfig = $vardir/localconfig
    report = true

/etc/sysconfig/puppet have:

PUPPET_SERVER=localhost.localdomain

And /etc/sysconfig/puppetmaster have:

PUPPETMASTER_MANIFEST=/etc/puppet/manifests/site.pp

I don't understand why puppet isn't installing packages that I putted in configuration. Did I missed something?

share|improve this question
1  
Please feel free to add your answer using the Post your answer button below. –  Ben Pilbrow Apr 20 '11 at 11:19

1 Answer 1

up vote 1 down vote accepted

Does your client resolve the fqdn correctly? run dig puppetmaster.domainname.com, and what result do you get?

also, did you configure the clients certificate on the puppetmaster?

share|improve this answer
    
I'm using /etc/hosts and localhost.localdomain for PUPPET_SERVER, and it resolves fine, not with dig but ping works. And certifications are not a problem, if you look at /var/log/messages you will see it doesn't complain about it. I had a problem when I used only localhost for PUPPET_SERVER, but now it works with FQDN. –  XoR Apr 20 '11 at 10:41
    
If it now works, then accept - or if I didn't understand, what's still wrong? –  Mister IT Guru Apr 20 '11 at 21:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.