Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

first time poster - long time reader and learner.

Have been trying in vain for 2 weeks now to sort out a messed up PHP5.3 install on a Debian 5 (lenny) box. Each time I attempt to apt-get install php5-cli I receive a waterfall of unmet dependencies and I really have no idea on where to start or how to take the box back to scratch.

Here is my list of unmet dependencies:

Reading package lists... Done
Building dependency tree
Rlibc6 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5-cli: Depends: libc6 (>= 2.11) but 2.7-18lenny7 is to be installed
        Depends: libdb4.8 but it is not installable
        Depends: libgssapi-krb5-2 (>= 1.6.dfsg.2) but it is not installable
        Depends: libk5crypto3 (>= 1.6.dfsg.2) but it is not installable
        Depends: libkrb5-3 (>= 1.6.dfsg.2) but it is not installable
        Depends: libncurses5 (>= 5.7+20100313) but 5.7+20081213-1 is to be installed
        Depends: libonig2 (>= 5.2.0) but it is not installable
        Depends: libqdbm14 (>= 1.8.74) but it is not installable
        Depends: libreadline6 (>= 6.0) but it is not installable
        Depends: libxml2 (>= 2.7.4) but 2.6.32.dfsg-5+lenny3 is to be installed
E: Broken packages

Here is my rudimentary apt/sources.list:

#
#  /etc/apt/sources.list
#

deb http://http.us.debian.org/debian stable all
deb http://security.debian.org/ stable/updates main contrib
deb http://packages.dotdeb.org/ stable all

Can someone please guide me in the right direction to sort out my php5.x install? (I do want -cli available as well - it's a Zabbix Monitoring server).

Thank you,

Edward

share|improve this question

1 Answer 1

Change "stable" to "lenny" (or "oldstable") in your sources.list -- "stable" is now squeeze, not lenny, so you're trying to install the squeeze version of php5-cli which has dependencies on lots of other squeeze packages.

share|improve this answer
    
+1 to that. (Don't forget to apt-get update after you've changed it) –  SmallClanger Apr 20 '11 at 8:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.