Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Some fast help on this would be good, I have been on this problem for 14 hours.

In a Virtualbox test environment I have 2 virtual machines networked together using a internal network (no traffic runs though the host, it is all at a software level). One is a fresh client with 512mb of ram and a dual core set-up, the other is the server with 1.5GB of ram and running server 2008 r2. The server is configured as a dns server, dchp server, domain controller and also serves PXE booting though WDS (Windows Deployment Services). Both machines can see each other and I am able to start a network boot.

The issue comes at the second to last stage of the pre windows PE install. On TFTP download of boot.sdi it starts it but stops during the boot process.

share|improve this question
    
Is there any more info you can provide to help diagnose the fault? How you configured ther server, for example. What happens when it fails? Which boot image you're using, etc... –  john Jul 27 '13 at 13:08

3 Answers 3

You need more than 512 MBs of RAM to boot a wim. WIM files are RAMdisk files so they need at least as much RAM as the file is big. Look at your WIM file and use that as the base amount of RAM to use with your machine. You should always add buffer space to the VM for processing at boot time. Some configurations are made and the only place to store them in a RAM OS is the RAM.

I add ~ 100 MBs as buffer but you should experiment around to get a good feel for you buffer. You might need more but most likely you would need less.

share|improve this answer
    
512 MBs of RAM would most likely work with Windows XP because it does not load into a full GUI. –  Elliot Labs Aug 24 at 13:28

Check the Windows Firewall setting. Make sure that the Incoming and Outgoing rules for the TFTP server is allowed for all profiles (public, private, work/domain).

Important: Double check the process referred in the rules! Yesterday, I nearly tore my hair out trying to get an L3 switch pick up its IP address from tftpd32.exe on my computer... only to find that the rule explicitly matched d:\tools\tftpd32.exe, while I've actually moved tftpd32 to d:\tools\tftpd32\tftpd32.exe. As soon as I changed the path in the rule, the L3 switch saw my TFTP server, and all is well.

share|improve this answer
    
I can though see in my event logs that downloads do start and complete without a problem. Also I tend to open the entire port instead of just the process for services. Also I have turned the firewall off with no effect –  Vbitz Apr 20 '11 at 21:06
    
@Vbitz downloads initiated by the VM or the host will not get affected because the destination of the initial TCP connection establishment is not directed to the host. And as to turning the firewall off: That's what I did with my tftpd32 woe. The firewall was turned off (got scary warnings from Windows), but the rule still stupidly gets applied. Try double-checking if Incoming and Outgoing rules for local UDP ports 67, 68, 69 (all UDP - DHCP and TFTP both use UDP) are all allowed. –  pepoluan Apr 20 '11 at 23:48
    
And still I have the same problem I currently have a rule allowing all traffic to go though on UDP ports 67-69. Still I have the same issue. –  Vbitz Apr 21 '11 at 0:36
    
@Vbitz ... okay, that stumped me ... can the DHCP and TFTP server be accessed from other VM? Say, boot using a LiveCD and access those ports. –  pepoluan Apr 21 '11 at 1:15
    
Just booted into Ubuntu 11.04, I was able to download the file no problems, also this is not a part file, they are both the same size down to the byte, also the whole file was downloaded in 3 seconds. –  Vbitz Apr 21 '11 at 2:06

Add more RAM to the client. Virtual NICs often behave strangely with tight memory.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.