Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently added a server to our network. After a normal RHEL5 installation I added a number of packages via yum. This was about 2 weeks ago.

This morning Im looking for something in yum and tried 'yum list <package>'. I got a large error:

Loaded plugins: rhnplugin, security
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in ?
  yummain.user_main(sys.argv[1:], exit_code=True)
File "/usr/share/yum-cli/", line 309, in user_main
  errcode = main(args)
File "/usr/share/yum-cli/", line 157, in main
File "/usr/share/yum-cli/", line 187, in getOptionsConfig
File "/usr/lib/python2.4/site-packages/yum/", line 665, in <lambda>
  conf = property(fget=lambda self: self._getConfig(),
File "/usr/lib/python2.4/site-packages/yum/", line 254, in _getConfig'init')
File "/usr/lib/python2.4/site-packages/yum/", line 179, in run
  func(conduitcls(self, self.base, conf, **kwargs))
File "/usr/lib/yum-plugins/", line 111, in init_hook
  login_info = up2dateAuth.getLoginInfo()
File "/usr/share/rhn/up2date_client/", line 219, in getLoginInfo
File "/usr/share/rhn/up2date_client/", line 186, in login
  li = server.up2date.login(systemId)
File "/usr/share/rhn/up2date_client/", line 52, in __call__
  raise self.__exception_from_fault(f)
Error Message:
Abuse of Service detected for server alice (1018572633)
  Error Class Code: 49
Error Class Info: 
 You are getting this error because RHN has detected an abuse of
 service from this system and account. This error is triggered when
 your system makes too many connections to Red Hat Network. This
 error can not be triggered under a normal use of the Red Hat Network
 service as configured by default on Red Hat Linux.

 The Red Hat Network services for this system will remain disabled
 until you will reduce the RHN network traffic from your system to
 acceptable limits.

 Please log into RHN and visit
 to contact technical support if you think you have received this
 message in error.

What did I do to trigger this? I tried the link but it doesn't go anywhere useful.

share|improve this question
up vote 2 down vote accepted

The problem was an errant process calling RH updater and locking up. Kill the process and wait a few days (or reset the acct with RH) 
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.