Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I disabled ESC in Server Manager on 2008 R2, originally just for Administrators but have tried to disable it for users and Administrators to try and solve this problem. Despite it being completely disabled I keep getting warnings as though it were still enabled.

You can see here I have it disable in my config and here is an example of the warning that I continually get, despite ESC being apparently disabled.

What changed in IE9 as far as the ESC goes that I can't disable it?

share|improve this question
1  
One Does Not Simply Disable "Enhanced Security Configuration" (reportedly the single most infuriating thing in the entire universe). –  romkyns May 4 '14 at 20:11

3 Answers 3

This may be a little bit outdated, but nevertheless, but probably somebody can found this helpful.

Try to set the registry IEHarden REG_DWORD key to 0 in regedit:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings\ZoneMap\IEHarden.

share|improve this answer

On my system, changing the value of IEHarden (REG_DWORD) to 0 in this key appears to have corrected the problem for all new accounts (and possibly some existing accounts):

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\
  Terminal Server\Install\Software\Microsoft\Windows\CurrentVersion\
  Internet Settings\ZoneMap

This is described (somewhat obliquely) in the Microsoft blog post, How to troubleshoot IE Enhanced Security warning "Content from the website listed below is being blocked by the Internet Explorer Enhanced Security Configuration" ?

It may still be necessary to change the corresponding setting (as per Volodymyr's answer) on a per-user basis for existing accounts.

share|improve this answer

This is an old thread but hey.

I had the same issue on a server 2008R2 Xendesktop deployed on hyper-v 2012 R2 using MCS from an image that already had this feature disabled. Despite Administrator setting the settings with Off for users and Administrators prior to MCS creating the base image, any user logging on, administrator or otherwise still has ESC enabled.

Before editing the registry i thought i'd try just enabling and disabling it again as an administrator and guess what...that worked.

gotta love the simple ones to fix. :-)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.