Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hey, I have a problem with xen networking. I'm using centos 5.5 64bit, and have installed xen 3.4 from gitco (unofficial) repository, along with libvirt and xen-tools. I got it previously working on official xen (3.2 iirc) without much of a hassle - I believe network just worked in default settings, with bridged settings (given that I provide= mac address for guest adapter that hetzner - my hoster - set up for me for my additional ip, my guest windows os will just found dhcp server and all will work automagically).

However, now I can't get it to work. If I leave default network-bridge xen settings enabled, my dom0 instantly gets down after reboot or xend restart. I don't really know what happens, since the only way to get my server back is to reboot it...

I've also tried routed setup, but I did not work after a few hours of struggling to set it up properly, so I eventually gave up, as it seems to be more challenging setup... so I'd rather try to get bridged attempt to work.

The settings in xend.sxp I want to use are:

(network-script network-bridge)
(vif-script vif-bridge)

Here is my ifconfig if I comment out everything network-related in xend.sxp along with the ifconfig after starting the network-bridge (i.e. there is already no connectivity when it happens - I've dumped it to the file): http://pastebin.com/nPT8nVBc - is the Bcast of 0.0.0.0 normal for the already-virtual eth0?

I've tried running the network script by hand to see what will happen:

cd /etc/xen
./network-bridge start; ./network-bridge stop

but no luck, it still goes down somewhere in the process and doesn't go back - restarting is the only way to get my server back.

Running

bash -xv ./network-bridge start 2>&1 | tee out.txt

gave me this output: http://pastebin.com/E6JPBb90 . Interestingly, the last line in ssh wasn't always the same: it would sometimes show up to the 305th line of the paste:

tdev=tmpbridge

the other it would stop at 530th line:

+ ip link show peth0

Still, I don't know wha could I make out of it or what else should I try?

Sorry for the lengthy description. I would appreciate all kind of suggestions.

share|improve this question
    
What does XEN 3.4 give you that the stock XEN in CentOS doesn't? If your config works under stock - then I would suggest running that. At least your production environment stays online working. –  Mister IT Guru Apr 20 '11 at 21:14
    
Unfortunately, xen version 3.4 is the first to be able to virtualize windows server 2k8 r2, which I intend to use... –  trakos Apr 20 '11 at 22:49
    
Hey! Finally, I got it working! I just copied the whole /etc/xen/scripts directory from the xen 3.2 that worked and voila! Everything's working as it should. Thanks for the help, you pointed me into the right direction :) –  trakos Apr 21 '11 at 0:14
add comment

1 Answer 1

up vote 1 down vote accepted

Hey! Finally, I got it working! I just copied the whole /etc/xen/scripts directory from the xen 3.2 that worked and voila! Everything's working as it should. As simple as:

mkdir xen303
wget http://mirror.centos.org/centos/5.5/os/x86_64/CentOS/xen-3.0.3-105.el5.x86_64.rpm
cd xen303
rpm2cpio xen-3.0.3-105.el5.x86_64.rpm  | cpio -idv
mv /etc/xen/scripts /etc/xen/scripts.bak
cp -pR xen303/etc/xen/scripts /etc/xen/scripts
rm -R xen303

and it looks like all the scripts are compatible with xen3.4, while working without further tweaking :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.