Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to install php-mcrypt on my CentOS 5.5 VPS, When I try yum install php-mcrypt, it says that it is set to be updated which implies that it is already installed. I looked in the /usr/lib/php/modules and cant find the .so file.

Anyway I want to update it but yum is giving the following error, I am running PHP-FPM on Nginx.

Last login: Thu Apr 21 12:13:30 2011 from cpc2-seve18-2-0-cust438.13-3.cable.virginmedia.com
[root@infinity ~]# yum install php-mcrypt
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-mcrypt.i386 0:5.1.6-15.el5.centos.1 set to be updated
--> Processing Dependency: php-api = 20041225 for package: php-mcrypt
--> Processing Dependency: php >= 5.1.6 for package: php-mcrypt
--> Running transaction check
---> Package php.i386 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php
--> Processing Dependency: php-cli = 5.1.6-27.el5_5.3 for package: php
---> Package php-mcrypt.i386 0:5.1.6-15.el5.centos.1 set to be updated
--> Processing Dependency: php-api = 20041225 for package: php-mcrypt
--> Running transaction check
---> Package php.i386 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php
---> Package php-cli.i386 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-cli
---> Package php-mcrypt.i386 0:5.1.6-15.el5.centos.1 set to be updated
--> Processing Dependency: php-api = 20041225 for package: php-mcrypt
--> Finished Dependency Resolution
php-mcrypt-5.1.6-15.el5.centos.1.i386 from extras has depsolving problems
  --> Missing Dependency: php-api = 20041225 is needed by package php-mcrypt-5.1.6-15.el5.centos.1.i386 (extras)
php-5.1.6-27.el5_5.3.i386 from base has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-5.1.6-27.el5_5.3.i386 (base)
php-cli-5.1.6-27.el5_5.3.i386 from base has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-cli-5.1.6-27.el5_5.3.i386 (base)
Error: Missing Dependency: php-api = 20041225 is needed by package php-mcrypt-5.1.6-15.el5.centos.1.i386 (extras)
Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-cli-5.1.6-27.el5_5.3.i386 (base)
Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-5.1.6-27.el5_5.3.i386 (base)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
[root@infinity ~]#

Any ideas?

share|improve this question
    
Please post the output of yum repolist –  dmourati Apr 21 '11 at 22:06
    
pastebin.com/X9jFvWKW –  Infinity Apr 23 '11 at 17:04
    
Maybe you are trying to install the wrong version of mcrypt. On my server I had to use php53u-mcrypt, for example. –  Rocket Hazmat Sep 21 '11 at 15:42
    
I'm still looking for a credible solution for this. –  Josh Apr 20 '12 at 17:41
add comment

2 Answers

Do you maybe have some excludes in /etc/yum.conf?

Run:

yum --disableexcludes=all install php-mcrypt

But be careful before you accept!

Cheers

share|improve this answer
    
Nope, nothing is excluded. pastebin.com/EvQkRX4f –  Infinity Apr 23 '11 at 17:05
add comment

Have you tried a yum clean all ? I've found that that can sometimes be helpful when yum seems confused.

Also try the following to make sure soemone has not inadvertently installed RPMSs of the wrong architecture - it's a long shot, but i've seen it happen

rpm -qa --qf %{NAME}-%{VERSION}-%{RELEASE}-%{ARCH}\\n |grep php
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.