Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I ran this command:

gem --version
1.3.5

I found it to be kind of strange since I didn't specify which gem I was asking about.

I am trying to install the rails gem like this:

gem install rails ERROR: Error installing rails: bundler requires RubyGems version >= 1.3.6

But I downloaded the latest gems version 1.7.2 but can't get it to be the system's default version. Any ideas how to manage this conflict?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Try

sudo gem update --system

to update rubygems to the latest version.

share|improve this answer

gem --version tells you the version of the RubyGems packaging system.

If you've installed a new version of RubyGems, it's probably been installed in a non-standard location. It didn't replace the old version of gem, and that version is still the one in your PATH. To run your version, execute it directly or put it in your PATH.

share|improve this answer
    
So is RubyGems a parallel product to RVM, and both are meant to help you manage your gems? –  Genadinik Apr 21 '11 at 22:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.