Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have recently installed windows update on my windows server 2003 machine. After updates when i open sql server 2008, i'm getting a wired error: 'Failed to open connection dialog - object reference not set to an instance of object (Microsoft.sqlserver.sqltools.VSIntegration)'.

I have tried these things to resolve this issue but couldn't get it fixed: 1. Run SQL agent service under 'Local System' account. 2. un-installed sql server updates. 3. Tried to repair sql server 2008, but getting error during repair.

Does anyone came accross with this issue and remember solution for it?

Thanks!

share|improve this question

migrated from stackoverflow.com Apr 22 '11 at 1:56

This question came from our site for professional and enthusiast programmers.

    
It looks like the error is probably related to Visual Studio Integration. Anything that you might have done related to that is probably to blame. –  pickypg Apr 19 '11 at 21:04
1  
Belongs on Server Fault –  wallyk Apr 19 '11 at 21:05
    
yea, i also think it's server issue. cause its a DB server and does't even have visual studio on it. I have also tried couple of options in 'Surface area configuration' with tcpip setting, but nthing worked so far. –  Deepak Apr 19 '11 at 22:43
add comment

1 Answer

Are you able to start SQL SErver services successfully? From Windows Event Veiwer logs check for APplication & System logs to see if there any other related errors.

The error you referred seems to be a tools problem, so you might try reinstalling Client components from SQL 2008 media. FyI there is no Surface Area Configuration tool in 2008 version, all such tasks can be managed using SQL Server Configuration manager.

share|improve this answer
    
Thanks Satya. yes, sql server service was working fine. couldn't find any solution with so end up completely uninstalling SQL server and reinstall it. yea, it was configuration manager (sorry about that). –  Deepak May 6 '11 at 14:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.