Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Tried these steps: http://www.how2centos.com/upgrading-centos-5-5-to-centos-5-6/

When I run yum update, I get the below

http://tinypaste.com/c8d9b2

Its not really 5.6, because I was originally on 4.8, then 5.3 and now these errors (even though it shows 5.6)

root@server [~]# cat /etc/redhat-release CentOS release 5.6 (Final)

root@server [~]# uname -a Linux server.domain.com 2.6.9-89.0.19.ELsmp #1 SMP Fri Jan 8 06:32:22 EST 2010 i686 i686 i386 GNU/Linux

share|improve this question
add comment

1 Answer

The link worked for me.

You don't provide the full output but one problem is that something is going wrong with the openssl package (which provides libcrypto.so.6). Look through the full output of yum update for mentions on openssl. What is the output of rpm -q -i openssl.x86_64 (assuming you are using the x86_64 architecture).

The guide recommends running yum update but it is better to use yum upgrade so that obsolete packages are handled.

share|improve this answer
    
tinypaste.com/dbec7 Please see that link. I really need help here –  Faith In Unseen Things Jun 2 '11 at 5:23
    
tinypaste.com/dbec7 Please see that link –  Faith In Unseen Things Jun 2 '11 at 5:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.