Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've followed the Solr tutorial, but the URL they make you use is:

http://localhost:8983/solr/ 

What is the most simple way to change this URL to:

http://localhost:8983/foobar/
share|improve this question

3 Answers 3

up vote 2 down vote accepted

I think I figured it out myself. What I did was, inside the example directory, rename

webapps/solr.war

to

webapps/foobar.war

Also, I changed a line in solr/conf/scripts.conf to

webapp_name=foobar
share|improve this answer

If you are running Solr with Jetty, you can change it in webdefault.xml. Detailed instructions here

share|improve this answer

Seems a little different in 2014 with Solr 4.10:

From the "example" directory or your equivalent:

  1. edit contexts/solr-jetty-context.xml <Set name="contextPath"><SystemProperty name="hostContext" default="/foobar"/></Set>
  2. edit solr/collectionName/conf/scripts.conf : change webapp_name=foobar
  3. java -jar start.jar

I'm not sure where the webapp_name parameter is used but it seems reasonable to keep this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.