Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am attempting to connect to a copy of Microsoft Office Accounting 2009 (running on Vista 64) from a laptop running XP home. I have done all of the MS steps (create user on Vista with same username and password, etc) and I can access files on the workstation from the laptop.

However, when I try to access the MS Accounting file I get the following error message

"The company could not be opened or access was denied. Please ensure that access has been granted and that the company database exists."

I then check the event log on the Vista 64 machine and get the following tidbits of information

SSPI handshake failed with error code 0x8009030c while establishing a connection with integrated security; the connection has been closed. [CLIENT: 192.XXX.X.XXX]

Any ideas anyone?

share|improve this question

3 Answers 3

up vote 0 down vote accepted

If you've been through all the settings correctly my guess is that you've got a firewall issue. You'll probably need to add an exception on the Vista machine to allow inbound SQL connections.

share|improve this answer
    
I've actually got the firewall turned off, I did all of the other steps listed on this problem, and now I get this additional line in the event viewer "Login failed for user ''. The user is not associated with a trusted SQL Server connection. [CLIENT: 192.168.1.109]" Also, I try to set the dynamic ports to 0 in the sql server configuration manager and it always resets itself to 59566. A most frustrating problem. –  Steve French Jun 29 '09 at 23:09
    
It sounds like the credentials aren't getting passed which is odd if the account is working fine for file access. Can you try turning on additional auditing in the local security policy to try to capture what account credentials are being passed when you connect. You should be able to see some Failure events in the Security log. –  Chris W Jun 30 '09 at 10:22

Also make sure that your SQL Server instance has remote connections enabled, it is off by default.

share|improve this answer

First off, Vista has specific security requirements for SQL 2005. Look into that. Install SQL 2005 SP2 or SP3 if you haven't already.

Secondly, check whether your SQL instance allows Windows authentication.

Finally, check whether the local Windows user has access to SQL and the necessary execute permissions. SSPI uses the credentials of the logged-in user.

There is a possible workaround, which I don't recommend: add a SQL user and change the connection string (if you can) to use this SQL user. That will bypass SSPI entirely. SQL has to be running in mixed mode, though.

share|improve this answer
    
SSPI is definately the culrpit here. Is the SQL server installed on the same machine as the SQL server? Or is your laptop XP Home and the SQL server is on your corporate network? –  Mark Henderson Jul 21 '09 at 23:06
    
Pft, sorry, I meant to say "is the SQL Server installed on the same machine that you are connecting from" –  Mark Henderson Jul 21 '09 at 23:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.