Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I go to the control panel, the drop down to change the automatic updates configuration is disabled. It says I need administrator access, but I have without a doubt an admin account.

Why is this disabled so I cannot turn of the automatic installation (and reboot) of updates in windows server 2008 r2?

Does this mean that the only account that can change this setting is the original admin account (username: administrator)?

A windows update recently caused the server to fail to boot up after restart!

share|improve this question
    
Is this a domain-connected machine? –  Vick Vega Apr 26 '11 at 18:18

3 Answers 3

up vote 5 down vote accepted

If this machine is connected to a domain, you are most likely under control of the Group Policy, which has been setup to not allow users to make changes to Automatic Updates, this may include administrators.

share|improve this answer
    
The same settings are also available through local policy, which would look the same. –  Chris S Apr 26 '11 at 18:50
    
DanBig is probably correct here. Also running GPResult ( technet.microsoft.com/en-us/library/cc733160%28WS.10%29.aspx ) should tell you what all the policies/setting are. –  Chadddada Apr 26 '11 at 19:04
    
Also, group policy overrides local policy. If that's the case, you're stuck with whatever update policy the domain administrator deems worthy. –  Hyppy Apr 26 '11 at 19:27

I know this is not of much help but before I join the machine to the Domain I make sure I setup the Windows Update settings correctly according to our policy. Otherwise what you see happens.

I would loging onto the server as the Administrator account for that machine and make the required changes.

share|improve this answer

Open Administrator Tools>>Group Policy Management. Find the appropriate policy. Computer Configuration>>Policies>>Window Components>>Windows Update

You should see settings set here that are overwriting your local settings.

share|improve this answer
    
I am in the process of obtaining the credentials for the "administrator" account - I'll check back as soon as I'm in and have taken a look. Thanks, Chris. –  Chris Apr 28 '11 at 8:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.