Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a reverse proxy server setup at my.mydomain.com which accepts traffic on port 80 and passes it to myInternalServer:internalPort (let's call it port 4545).

Everything works fine as far as accessing unsecured services go. When trying to log into to the REST login page by going to my.mydomain.com/arcgis/rest/login (by clicking the login link on the upper right)

I get the login page, when look at the page source, I notice that the redirect for the button is my.mydomain.com:4545/arcgis/rest/services which is wrong. When I my server using the internal address myInternalServer:4545/arcgis/rest/login all is well and I can log in.

share|improve this question

migrated from gis.stackexchange.com Apr 26 '11 at 19:33

This question came from our site for cartographers, geographers and GIS professionals.

1  
if you get no luck in here (give it a week) maybe see if ServerFault can assist. –  Simon Apr 22 '11 at 6:22
    
Did you follow the steps in this knowledgebase article? –  Kirk Kuykendall Apr 22 '11 at 13:25
    
Why is "my.mydomain.com:4545/arcgis/rest/services" wrong? doesn't it get you to where you want to go? Are you using JAVA or .NET version of arcGIS? –  capdragon Apr 22 '11 at 15:01
    
Also, What redirect button are you talking about? The login button? –  capdragon Apr 22 '11 at 15:03
    
...moving to ServerFault. I think the problem & solution are more likely to be related to general server setup and not specific to GIS (and no one here on GIS.se seems to have ideas on how to help). –  matt wilkie Apr 26 '11 at 19:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.