Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install Powershell 2.0 on a Windows Server 2008 SP2 box. According to the Microsoft download page, I need KB968930-x86.msu. I have downloaded that, but when I try to install it, I get "Update does not apply to your system".

Can someone let me know which file I need to download to get Powershell 2.0 on 32-bit Server 2008 SP2?

Thanks

share|improve this question
1  
Check the Powershell version first: > $psversiontable.psversion stackoverflow.com/questions/1825585/… –  Davidw May 27 '13 at 18:45
add comment

1 Answer

You may have already installed it. Go into Programs/feature and add a windows component. Look for powershell, check it to complete install.

Heres the link for the Win mgmt framework. Pick the correct install from the bottom of the page and follownthe install instructions WimMgmt KB article

share|improve this answer
    
I am running Windows 2008. There is no option to add a windows component in Windows 2008. I looked in features in server manager and Powershell 1 is installed, but I'm trying to install Powershell 2.0. Please let me know how to install Powershell 2.0 on Windows 2008. Thanks. EDIT: I tried installing Powershell 2.0 without version 1.0 installed and got the same results. –  Jay Apr 27 '11 at 2:05
    
In added a link to the correct download page. –  uSlackr Apr 27 '11 at 2:49
    
If you go to that link, it will tell you to download KB968930-x86.msu. This is the file that tells me "Update does not apply to your system". –  Jay Apr 27 '11 at 13:06
    
This article suggest you go to Add/Remove programs and click show updates. Then uninstall KB926139. After removing it, try reinstalling the update. powershell.com/cs/forums/p/2977/3998.aspx –  uSlackr May 5 '11 at 2:40
    
There is no software named KB926139 on my system to uninstall. This article suggest that Powershell 1 needs to be uninstalled. I get the same error message with or without it installed. –  Jay May 5 '11 at 17:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.