Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have installed mod_mono and apache as per the instructions mentioned

in

http://blog.ruski.co.za/page/Install-Mono-on-Ubuntu.aspx

when i run i also get the error message mentioned towards last.

but when i hit

http://localhost/test/index.aspx

i get following error

Server Error in '/' Application The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Resource URL: /test/ Version information: Mono Version: 2.0.50727.1433; ASP.NET Version: 2.0.50727.1433

what is the problem ? i am so near yet so far !

share|improve this question

migrated from stackoverflow.com Apr 27 '11 at 6:44

This question came from our site for professional and enthusiast programmers.

    
This is not the right forum for the question. Either try serverfault or post to mono-list (mono-project.com/Mailing_Lists) –  Gonzalo Apr 10 '11 at 5:24
1  
Just to commiserate, I'm experiencing a very similar problem myself, though on a brand new RHEL machine. –  WCWedin Apr 27 '11 at 16:19

1 Answer 1

Perhaps you've tried this already, but it's worth mentioning:

Mono will return a 404 if you request a file it doesn't have permission to access. When I was having the same problem, I tried absolutely everything else I could imagine, including some 20 different conf files and about four hours a-Googling. In the end, a simple cd to the app directory followed by chmod -R 755 did the trick.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.