Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to get Jakarta Connector to work on my Windows 2003 Box, with IIS 6. I downloaded the latest version of the connector. Whenever I try to access the redirector I get a "You are not authorized to view this page - HTTP Error 401.3" in my isapi_redirect log the last line is always

[debug] HttpFilterProc::jk_isapi_plugin.c (2079): [/jakarta/isapi_redirect.dll] is not a servlet url

Anyone have any ideas on what is going on and why I cant get this to work.

share|improve this question
add comment

3 Answers

up vote 0 down vote accepted

It's possible that you're seeing this because the isapi extension has not been allowed on the site you're installing the connector on. Go to Web Service extensions and create a new extension, name it "jakarta connector" and input the path to the isapi_redirect.dll and then check the box to enable it.

share|improve this answer
add comment

The Jakarta redirector is now part of Apache. The latest is 1.2.35 which now is very similar to the Apache httpd jk.mod module for redirecting.

Thus the syntax for mount points in the unirworker.properties file is as follows -

/arsys|*=worker1
/manager|*=worker1

The pipe "|" and star "*" versus just a "/" is the apache difference in the redirector.

Thus to solve the problem of /arsys is not a servlet url - change in the uniworkers.properties from /arsys/* = worker1 to /arsys|*=worker1.

share|improve this answer
add comment

You dont provide enough information to solve it, but I can told you some checks I have done in similar problems.

First of all, The website and the alias "jakarta" must have correct permisions - In IIS, execute permision - In the windows folder, Read permisions for ASPNET User adn IIS Process user

Second, remember to ALLOW the .dll manually from the extension menu

Third, All the files (worker, urlredirector, ...) must have correct permisions too, and they can be on different folders.

Check those points and provide us feedback so we can help you.

share|improve this answer
    
What other Information should I provide? Also I have scripts and executables enabled in my site, and the alias. The permissions for the ASPNet user should be correct. I have allowed access to the DLL. What permissions do the worker files need? Thanks for your help –  josephs8 Apr 27 '11 at 14:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.