Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My server OS is Ubuntu 10.04/x86 and now I set the bind's configuration file same as another host (which is Debian 5), and ran /etc/init.d/bind9 start. This shows me OK. I then run rndc reload, which returns successful.

I setup the NS server in my domain name's register. But now, I use the command in client console. C:\>nslookup domain dns-ip and is shows me server fault.

So, I want to know what is wrong. I didn't set firewall or other filter system. I tried to visit http://who.is/ to find the all DNS information, but no record shows, only the 2 NS server which I set was shown.

I have set the bind9 using the same steps in Debian 5 and it's worked well. Does Ubuntu need additional configuration?

share|improve this question
    
Bind logs error messages to syslog when you start or restart it, you'll need to check the log files to see what's wrong, probably /var/log/daemon.log –  DerfK Apr 27 '11 at 14:43
add comment

1 Answer

look into /var/log/messages or /var/log/daemon.log

if is the server fault then you have some typo(mistake) into the config files - /var/named/* or /var/named/chroot/var/named (look into /etc/named.conf to what is configured)

chek from the server itself as in

host some_name_in_my_list 
share|improve this answer
    
Or dig @localhost somedomain.com –  3molo Apr 27 '11 at 17:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.