Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is driving me batty. I have a Windows SBS2003 machine to which I can connect via RDP as long as I'm on the LAN. I cannot, however, connect over the WAN. I've set up NAT on the Linksys router that sits between the LAN and WAN to direct inbound traffic on port 3389 to the server's IP. I've confirmed that the server is responding to RDP requests on port 3389. The server has a single NIC, so RRAS shouldn't play in to this. The only thing I can figure is that somewhere there's a setting I'm missing where one can define "Grant access for all IPs except the following" or "Deny access for all IPs except the following" (much like you'd set in the security settings for IIS sites).

Can anyone help shed some light on this?

share|improve this question
    
You need to define 2 settings: 1. Create an appropriate firewall rule. 2. Create an appropriate virtual server port forwarding rule. –  Vick Vega Apr 27 '11 at 16:45

1 Answer 1

up vote 0 down vote accepted

Since you are using a Linksys, you might try disabling SPI (Stateful Packet Inspection) if it is enabled (and the setting exposed within the Linksys interface). You can also telnet to the port from the WAN side to see if it is at least responding to the connection request.

share|improve this answer
    
The current firmware version on the BEFSR81 doesn't provide an option to disable SPI. I'll upgrade the firmware and see if the option becomes available. Regardless, I think you've somewhat confirmed a notion I've had... that the router is at fault. I'll post back later with my findings. Thanks! –  Joe Apr 27 '11 at 16:48
    
You might also consider rolling back as well, if there is anything pre-SPI. –  user48838 Apr 27 '11 at 17:29
    
Your comments about the Linksys got me thinking about whether perhaps the device itself was faulty. I replaced the router, set NAT accordingly on the new router and Viola! Everything worked as expected. –  Joe May 23 '11 at 12:49
    
Glad it worked out for you. Linksys is usually not the first choice for hosting network resources. –  user48838 May 24 '11 at 2:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.