Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've setup a desktop machine with OpenSUSE 11.4 and have Active Directory authentication working properly. I can ping, rdp and ssh to'/from other machines. I can access windows shares from OpenSUSE and samba shares from Windows. However, the hostname won't resolve from any machine on the domain. I can ping other machines on the LAN from OpenSUSE using hostnames, but from the other machines I can only use the IP of the new machine. What am I missing?

share|improve this question

3 Answers 3

You need to register your host with the DNS system - either from updates by the DHCP server or by manually entering the correct A and PTR entries so that other domain members can resolve.

NetBIOS name resolution is (hopefully) not used anymore as it is everything that the gods have forbidden.

share|improve this answer
    
Take a look at this post. It has good information about a netbios "free" network: serverfault.com/questions/119253/netbios-free-network –  Bob Rivers Apr 27 '11 at 20:28

I had similar problem and solution I found realy simple but it is in dhcp server.

The problem is windows server does not use dhcp server to maintain dns records by default, and uses it's own way. You need to setup account for dhcp server in AD, like dhcp4dns, and include it in group DNS Update Proxy, then in DHCP server in properties setup account for DHCP to interact with DNS, and you're done.

share|improve this answer

Have you allowed NetBios in the firewall?

You can update this in two ways:

  • In the Administrator Settings (YaST), look for Firewall (probably under Security and Users). Run this, and select the Allowed Services item. Under the Service to Allow, select Netbios server, and add it to the list.
  • In the Administrator Settings (YaST), look for Samba Server (probably under Network Services). Run this, and in the Start-Up tab, select the Open Port in Firewall option.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.