Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

... the title is not strictly correct. I can "save-as" over the top of the same file via the UNC path. Yes, that's weird. Trying to save-as over the top of that again via the mapped path triggers a sharing violation, as you would expect.

I get this in AutoCAD and Excel. It is intermittent and happens rarely.

Sometimes in Excel the file will open and then, about 10 seconds later, I get a dialogue saying the file is available as read-write. Um, thanks - that's the way I opened it.

Client is Windows XP sp3. AV is Symantec Endpoint. Neither was my choice.

Server is Windows Server, 2008 (not R2 - that would be modern), I think.

share|improve this question
1  
Are you able to reliably reproduce the issue? Specific user, specific way of logging in, ie terminal server, RDP into the XP SP3 machine, just console? If you copy the file locally, can you reproduce the issue ever? Does this happen when opening it directly through the UNC path, ie \\server\share\name.xls? Does it happen when opening Excel first, then opening the file (I ask the two, because I've ran into issues with one working and the other not). What version of Office is on the machines? –  Nixphoe Apr 28 '11 at 2:21
    
I am using the XP machine directly as a domain user. Copy to local works fine. I work mostly in AutoCAD so that's where I see it most often. Issue is not reproducable (Yay!) - the same workflow produces different results. Today's workflow is 1. open a read-only drawing, 2. Save-as using the mapped path, 3. work on the drawing, save. Repeat 3 until finished. About 1/5 of the time it fails one of the the saves in step 3 so I save-as it via the UNC path. Issue does not re-occur after saving via UNC. Excel is 2007. –  CAD bloke Apr 28 '11 at 2:30
1  
How does your drive map? Via login script? If you remove it and manually add it in fromt he command prompt, or from Add Network drive from My Computer does the issue happen again? Though it seems backwards, if you go to Control Panel > Users Accounts > Advanced tab > Manage Passwords; do you have anything listed there? –  Nixphoe Apr 28 '11 at 2:46
    
Client PC is a corporate SOE so I don't have much control over it. Drive maps via a login script. I have remapped the drive and will report back on progress. There are 2x local server IP addresses in the Manage Passwords tab. I seem to be the only person here (of about 50) complaining about it so it is likely to be a local issue. –  CAD bloke Apr 28 '11 at 2:58
    
... and thanks very much for your time on this. :) –  CAD bloke Apr 28 '11 at 2:59

2 Answers 2

up vote 1 down vote accepted

Check Control Panel > Users Accounts > Advanced tab > Manage Passwords; if you have anything listed there it could be an old password it is trying to use to connect to the server.

share|improve this answer
    
Remapping the drive seems to have made it a lot more responsive. Could be a placebo effect but so far, no errors. Is it safe to delete all the entries in Manage Passwords? I have no way of telling what the IP addresses map to, other than one of the boxes has IIS on it. –  CAD bloke Apr 28 '11 at 3:20
    
Remapping the drive seems to have worked, as per @Nixphoe's comments above. Thanks for your help. :) –  CAD bloke Apr 28 '11 at 4:14
    
erm, yes ... "Have you tried turning it off and on again?", in a manner of speaking. Um, duh Me. –  CAD bloke Apr 28 '11 at 4:25
    
you could try a ping /a to see if it will reverse the name of the server. If it's a domain managed server and you normally have access to it, should be safe to delete the entries in Manage Passwords. –  Nixphoe Apr 28 '11 at 13:50
    
Thanks. That was handy. Neither of them are the server in question. –  CAD bloke Apr 28 '11 at 22:57

Make sure the file is not being previewed by Windows Explorer. A file in the Preview Pane of Windows will lock a file and mark it as in use.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.