Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server running in the azure cloud. The server is a DC and i'm trying to make a domain trust with my local domaincontroller Server. The servers are linked with windows azure connect (ipsec).

I can ping from cloudpc to localdc.
I'm also able to add the dns records of the localdc.

But now i'm trying to make a trust with the localdc.. I Go to Trusts tab, click New Trust, enter localdomain and click next and get "The name you specified is not a valid Windows domain name..." and it won't let me continue.

I don't want to give up because it worked once, but now the ipv6 of the azure connect changed so i had to reconfigure. I have already spent 2 days on this.

The way we solved the trust problem before was by adding the 127.0.0.1 address to the prefered dns of my network adaptor.
It seems the dnsrecords of the previous settings remained and the new address made the trust work.
However, if i try this workaround again, the azure connect records just reset and seeing this is the base of the connection, it is important these stay unchanged.

It seems logic that it is a DNS problem, but I am puzzled as to how to solve it.

If anyone got through reading all of this and still understood my blabbering... ;)
Any thoughts would be greatly appreciated

share|improve this question

2 Answers 2

By default you have to open firewall ports between the systems. I was just reading about it here, but you'll have to open additional rules for AD. Checkout the dcdiag and addiag commands to test AD communication.

share|improve this answer

Your problem seems related to Name Resolution. Validate that nslookup, on both environments properly resolves the names for the DC that you're planning to connect.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.