Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have CentOS server installed in virtualbox running on windows 7 host. The CentOS client has internet access if I select NAT, but if I select 'bridged' then it has no internet access.

I have to use bridged because I need the CentOS client to have its own unique public ip address, and as far as I know NAT doesn't provide that.

Does anyone know how I have to configure CentOS, or virtual box, to give the cents client internet access in bridged mode?

share|improve this question
how is your windows subnet getting ip addresses? DHCP or Static (normally it's dhcp). If DHCP, then what are you doing to configure for DHCP? – Mike Pennington Apr 28 '11 at 18:08
i'm using dhcp, ipconfig /all says that it is that is the dhcp server. I have no idea how to configure centos however to work with bridged. – aieee3 Apr 28 '11 at 18:42
up vote 1 down vote accepted

There are few issues:

  1. Are you sure your address provider is allowing you to pull multiple IP addresses? In the case of many cable/dsl modems, you are often prevented from using the network with multiple machines simultaneously. In many cases, you can get a second DHCP lease from the modem, but it will only communicate with one.

  2. You mention that your DHCP server is, this is a private IP address... which implies it's either from your home network, or from a customer-side DSL/cable modem. If you wind up with a 192.168.x.x DHCP address, be aware that traffic will not be talking directly to the IP address of your Linux machine. If you truly need a public IP, you will need to work with your ISP to understand what is happening.

  3. If you're sure that you should be able to get a public IP address, then Configure your CentOS machine for DHCP

share|improve this answer

Centos - change network settings from a terminal, set network to DHCP or assign an address in the allowable range.


Do you have two NIC's. Common problem. Two NIC's but only one is plugged in and the other is the one that was bridged. You can either bridge both NIC's or switch the wire to the other NIC. Also applies if you have one NIC and a seperate wireless adapter. I usually bridge all interfaces including wireless to make life easier during install/testing. After the first virtual in configured you should be able to re-configure for just the bridge(s) needed.

Install tcpdump on the Centos virtual and look for arps to help diagnose if needed.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.