Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

svccfg -s network/inetd setenv UMEM_DEBUG default,firewall=1

this command is not working. I need to set an environment variable to the inetd service with "=" as a character in environment variable value.

share|improve this question

1 Answer 1

If I read your command correctly you want to set the value of UMEM_DEBUG to default,firewall=1

You can do this interactively

svccfg -s network/inetd 
svc:/network/inetd> setprop start/environment=astring ("UMEM_DEBUG=default,firewall=1")
svc:/network/inetd> listprop start/environment
start/environment    astring    UMEM_DEBUG=default,firewall=1
svc:/network/inetd> 
share|improve this answer
    
quotes shouldn't be part of UMEM_DEBUG env value. –  suresh Apr 29 '11 at 11:50
    
Firewall is an hidden option in umem –  suresh Apr 29 '11 at 12:46
    
@suresh: Have a look at the changes I made –  Iain Apr 29 '11 at 13:28
    
@suresh; please post corrections as a comment, Iain will edit them into his answer if he thinks they are appropriate. Thank you! –  Chris S Apr 29 '11 at 15:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.