Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I had an electricity cut while I was upgrading from Ubuntu 10.10 to 11.04, now when booting the system I get the following message:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Any ideas how to solve this?

share|improve this question
add comment

3 Answers

At the grub boot menu if you type e to edit the grub configuration for the line you've selected you'll see a line something like this:

linux /boot/vmlinuz-3.0.0-12-generic root=UUID=ddbfffc1-731c-4931-9129-75c5f42f8ecb ro single nomodeset

The culprit is the root=UUID=ddbfffc1-731c-4931-9129-75c5f42f8ecb part which probably still has the old UUID or partition listed. If you know the specific partition you can either set it to something like root=/dev/sda1 (or whatever your partition number is) and then type ctrl-x to boot or you can substitute the correct UUID which you can find by booting with a rescue disk and running the blkid command.

If you're lucky and your root partition has been properly labeled then you could also try root=LABEL=/.

share|improve this answer
add comment

this goes after grub? if yes - you can change yours grub settings for hd and init=/bin/sh and run something like fsck

share|improve this answer
    
Can you explain more? as a start it says: The disk drive / is not ready yet or not present, but when i go to console, I can access all files –  khelll Apr 29 '11 at 13:53
    
how you access that files? you can try to check blkid /etc/mtab and grub configuration if UIDS are correct. –  MealstroM Apr 29 '11 at 13:57
    
I went with the recovery mode and it said it can't mount drives then it gave me the console. Using it I can access files with no problems. Not sure what to do with the commands u specified above. –  khelll Apr 29 '11 at 14:08
    
can you show yours /boot/grub/grub.cfg and command /sbin/blkid result? –  MealstroM Apr 30 '11 at 12:35
add comment

I had this problem once, way back with... I think it was Ubuntu 7. The Disk UUID's changed, I can't remember why.

I mounted manually, edited /etc/fstab and replaced the UUID entries with actual partitions (eg: /dev/sda1, /dev/sda2 and so on) and rebooted.

share|improve this answer
    
I am sorry to say that I have the same problem. But, unfortunately, comment from Some Guy couldn't help me because the UUID value in fstab actually matches the output of blkid. BTW I tried to use /dev/sda1 instead of the uuid, but it didn't help. –  user79943 Apr 29 '11 at 22:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.