Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to perform a search in a manpage, which requires the Enter key to achieve. However pressing it displays the word ESCOM instead of the desired function.

The Enter key works as it should in other areas such as the command line, or vim.

Couldn't see anything in PuTTY options other than a setting under "Terminal" labelled "Implicity CR in every LF" however enabling this has no effect.

The only related info I could find was at https://bugs.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/40905 however this thread seemed to fizzle out without any solution, and the reporter was experiencing the issue in seemingly many applications, whereas I can only replicate in 'man'.

Thanks for any advice!

EDIT: Actually it seems I am having trouble with vim now, which is odd as it wasn't occuring earlier, not sure exactly what I'm doing differently.

Trying to :wq in vim creates a new line with 'M' in it, in the same fashion as the vim keys 'OM' would do.

EDIT 2: Ok, I've just noticed that if I use my laptops FN + Enter, I'm able to press Enter.

This is still not ideal, but at least I can save my vim changes now!

share|improve this question

2 Answers 2

It looks like your man command is having issues, see the man man page.

http://linux.about.com/od/commands/l/blcmdl1_man.htm

Specifically, it seems that your less command is having issues.

-P pager Specify which pager to use. This option overrides the MANPAGER environment variable, which in turn overrides the PAGER variable. By default, man uses /usr/bin/less -isr.

Hitting Ctrl-J should get around the issue for now, see:

https://bugs.maemo.org/show_bug.cgi?id=6009

Also, this issue may be related to which enter key your keyboard maps to:

http://superuser.com/questions/142579/unix-less-problem-with-enter-key-on-numeric-keypad

share|improve this answer
    
Thanks a bunch :) –  DanH Apr 29 '11 at 18:34
    
Sorry, keep coming back to this problem and realised I shouldn't have marked your reply as the definitive answer, apologies if that's naughty. Currently however, problem still not solved, although you did help me "cope". –  DanH May 13 '11 at 12:41
    
Not a problem, I'll vote up the question to see if it can get some more views. –  Flashman May 16 '11 at 12:55
up vote 1 down vote accepted

In PuTTY Settings > Terminal > Features > CHECK Disable Application Keypad Mode

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.