Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Please ignore the partial rant that will follow:

I have a simple windows 2008R2 VPS, running a few sites.

I wanted to add an FTPS, you know like most normal people do....

So began the journey of pure frustration.

I mean does it really, really, really need to be this difficult?

This is what I've done so far:

(1) Created a folder in the ftproot directory. Lets call this "MrFoo"

(2) Created a new user lets say "MrFooUser" and associated password

(3) Created a domain to point to my server e.g "MrFoo.co.uk"

(4) Using the IIS 7 wizard created an FTP site, made sure the bindings are for "MrFoo.co.uk"

(5) Made sure that it uses SSL (using self certification).

(6) The FTP site is on port 21 (As I heard there are issues with port 990)

(7) Set up Permissions, Authorizations, etc for the "MrFooUser"

(8) Set up Folder isolation to first option

For the

love of sanity

can some-one post a "step by step" idiots guide to setting up a simple FTPS on IIS7 (I think I may have IIS7.5 actually) that works...

rant over.

share|improve this question
1  
Maybe you should tell us why your current procedure doesn't work - i.e. the problem you're having –  Mark Henderson Apr 29 '11 at 22:11

1 Answer 1

(it's unfortunate you're frustrated, but you haven't posted anything useful to troubleshooting the problem, you've stopped at the end of the setup steps and at the point at which there's presumably some sort of error?)

Psychic debugging: Your problem is that you're using the virtual host support, and you haven't read the documentation closely, and have assumed that something intuitive, like "user@domain.com" is the correct syntax for multi-host FTP support. It isn't.

The username syntax for such a setup is:

your.ftp.site|administrator

Yep, with a pipe character after the virtual host name, and before the username. Weird. But documented. http://learn.iis.net/page.aspx/320/using-ftp-virtual-host-names/

Unless you've set useDomainNameAsHostName, which you haven't mentioned. http://blogs.iis.net/jaroslad/archive/2009/04/16/addressing-the-separator-problem-for-virtual-ftp-sites-ftp-7-5.aspx

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.