Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a OS X Snow Leropard Server running and I want to disable multivewis from Apache. I could add Options -MultiViews to each .htacces file I have, but I guess there must be a global option. Disabling mod_negotiation.so renders all pages useless so this is not the option I'm looking for ..

Thanks for the help!

share|improve this question

migrated from stackoverflow.com Apr 30 '11 at 5:20

This question came from our site for professional and enthusiast programmers.

2 Answers 2

Considering this is OS X, one snag I ran into was my user specific declarations (in the users/username.conf subdirectory of apache2) had MultiViews turned on, overriding httpd.conf.

MultiViews was substituting /search.php for /search, messing up the "pretty" Codeigniter urls on my dev machine.

share|improve this answer

In /etc/apache2/httpd.conf you should find the section starting <Directory "/Library/WebServer/Documents"> and remove MultiViews from the Options directive there. The same goes for any other paths if your content isn't in that directory.

As an aside, if you're able to edit the server's main config file you should never have to use .htaccess file. Doing so only slows down the server, makes tracing the configuration harder and makes any use of mod_rewrite a brain-rending disaster.

share|improve this answer
    
I couldn't find <Directory "/Library/WebServer/Documents"> but I have added the following: (to no success): <Directory "/"> Options FollowSymLinks Options -Indexes Options -MultiViews AllowOverride All </Directory> –  Sorin Buturugeanu Jan 21 '11 at 19:33
    
There's no need for your multiple Options directives. If you specify e.g. Options FollowSymLinks without any +/- modifiers then that is taken as the complete set of Options. It's generally a bad idea to mix relative and absolute Options arguments, especially on the same line. –  noodl Jan 21 '11 at 19:54
    
Regarding your choice of Directory path, you should note that any directories "closer" to the real one will take precedence. For that reason you should look through all your config files and possibly any vhost declarations for Options directives that could be overriding your own. –  noodl Jan 21 '11 at 19:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.