Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have log entries like:

Apr  8 10:25:31 monitor postfix/smtpd[3131]: connect from localhost[127.0.0.1]
Apr  8 10:25:31 monitor postfix/smtpd[3131]: lost connection after CONNECT from localhost[127.0.0.1]
Apr  8 10:25:31 monitor postfix/smtpd[3131]: disconnect from localhost[127.0.0.1]

every minute or so on a central rsyslogd log monitoring box from all local/remote nodes (Debian Squeeze, Rsyslog 4.6.4, Postfix 2.7.1 both from repos), I've tried to disable info messages in /etc/rsyslog.conf by commenting out the line:

#mail.info                      -/var/log/mail.info

and also adding a line

*.*;auth,authpriv.none,cron.none,mail.none -/var/log/syslog

which I thought would disable all mail logging from Postfix into /var/log/syslog, but it doesn't help. I have searched for other mail.info mail.debug entries and there are none, just one entry like:

mail.*                          -/var/log/mail.log

which I've commented out too, but then I think that shouldn't cause logging to /var/log/syslog anyway, no?

share|improve this question

migrated from stackoverflow.com Apr 30 '11 at 6:05

This question came from our site for professional and enthusiast programmers.

1 Answer 1

You are using the wrong syntax, you have to use ";" as a delimiter.

This worked for me:

*.*;mail.none;mail.error;auth,authpriv.none             -/var/log/syslog

You need to restart rsyslog after the changes. Reloading isn't enough.

share|improve this answer
    
Worked like a charm, thanks. –  silviot Dec 2 '12 at 14:10
    
In ubuntu 14 the file to edit is /etc/rsyslog.d/50-default.conf –  Richard Jun 3 at 15:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.