Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Red Hat server, Red Hat Enterprise Linux Server release 5.2 (Tikanga), and I am trying to start Varnish on it. When I try to start Varnish, I always get the following exception,

Pushing vcls failed: dlopen(./ ./ cannot open shared object file: Permission denied

I have another, identical server that does not have this issue. I installed Varnish on the Red Hat server following the directions outlined at

Is there some configuration issue that needs to be tweaked to keep this issue from occuring? My initial investigation and thoughts was that the server did not have enough disk space, but I believe I have cleaned up enough free space.

share|improve this question

migrated from Apr 30 '11 at 6:13

This question came from our site for professional and enthusiast programmers.

I ran into this problem by restarting Varnish, problem was my umask.

share|improve this answer
The Debian init script has a similar problem with umask:… – gioele Aug 17 '12 at 19:43

Could be a number of things, but I had this error with Varnish on Ubuntu, and it was because I had /var mounted as -noexec. Removing the -noexec attribute in /etc/fstab fixed it.

share|improve this answer

Selinux might be the cause. Check your audit log (/var/log/audit/audit.log) for alerts. If there are any, you might want to use something like audit2allow in order to add more selinux rules.

share|improve this answer
up vote 0 down vote accepted

We fixed this problem by deleting the file and restarting Varnish. On the restart, the file was recreated and there were no longer any issues.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.