Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After optimizng the fstab values for my main server HDD, the server is unable to boot and i can't debug it because i'm controlling it remotly, this what i've entered

/dev/sda1 / ext3 defaults,usrquota,noatime,nodiratime,data=writeback,commit=30 1 1

proc /proc proc defaults 0 0

sysfs /sys sysfs defaults 0 0

/dev/sda2 swap swap defaults 0 0

none /dev/pts devpts rw 0 0

none /var/tmp tmpfs

defaults,rw,noexec,nosuid,noatime,nodiratime,size=3g 0 0

tmpfs /dev/shm tmpfs defaults 0 0

What is wrong with those values? i'm using centos 64bit

share|improve this question
Does your server have enough RAM to support a 3 gigabyte tmpfs RAM disk? – LawrenceC Apr 30 '11 at 18:31
I have 8G.B RAM, what you think? – danswano May 2 '11 at 9:54
Be more specific about "unable to boot." – Michael Martinez Oct 16 '13 at 18:33

Are these two separate lines in your fstab?

"none /var/tmp tmpfs

defaults,rw,noexec,nosuid,noatime,nodiratime,size=3g 0 0"

If so, that is a problem.

Even if they are a single line, I think it is still a problem. Except for "size=3g", none of those options you specified are valid mount options for a tmpfs. You can view the valid options in the manpage for mount.

share|improve this answer
They are single line but i saw those values used already on a box, how they managed to boot with those values? – danswano May 2 '11 at 9:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.