Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The django app at halfcan.org is hosted on an Amazon ec2 micro instance. I can access it from my computer and from my phone on the same wifi. But anyone else gets a long wait and then "problem loading page",. Here is what I know:

  • it's not a browser problem: they have tried IE and firefox with the same result
  • dns has been set up for a week and is propagated: the A record is set to 50.19.108.242
  • 50.19.108.242 is an Amazon elastic IP which is connected to my instance
  • the frontend server is nginx and it logs accesses and errors when I connect, but nothing when other people try.
  • so it appears the DNS or elastic IP is not working for them, but it is for me. How can that be? How do I debug that?
share|improve this question

migrated from stackoverflow.com Apr 30 '11 at 23:32

This question came from our site for professional and enthusiast programmers.

    
Are you sure you switched your development environment from development to production via toggling the DEBUG value in settings.py? It may be that some resources have their path hardcoded to your localhost and not your server's path. –  Gisborne Apr 30 '11 at 17:14
    
Answer: the Amazon security group was set wrong. It was set to only allow access from my IP. –  Anonymous Apr 30 '11 at 17:15
    
The site isn't even accessible via 50.19.108.242. Are you sure there's no firewall or similar set up on the instance itself? –  middaparka Apr 30 '11 at 17:16
1  
Works now, it seems. –  Erik Apr 30 '11 at 17:21

1 Answer 1

Check the Amazon security group settings and see what they say.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.