Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I added a Scheduled Task on my Windows 2008 R2 Domain Controller in the Group Policy Manager:

MyDomain Policy

User Configuration

Preferences

Control Panel Settings

Scheduled Tasks

Basic Task, like starting notepad, when user unlocks his workstation.

This should show up in the client workstation's task scheduler, but it dosn't. No errors or anything like that.

If I use the "Computer Configuration" instead of "User Configuration" the task appears, and I'm able to run the task.

I've tried the gpupdate /force followed by gpresult and checked the report, but it dosn't contain the GPO Scheduled Tasks I created? (again, does show up when using "Computer Configuration".)

The issue is that I have to run the application in the current users context, and only on a specific Employee OU, and thereby limit this task only to Employee Workstations and not apply the application when the same employee log on to internal servers and such.

Primary domain dontroller is a Windows 2008 R2, workstations Windows 7 Enterprise.

What am I doing wrong ?

share|improve this question
add comment

3 Answers 3

I have been researching a similar problem for several days and came across this post in my search. I finally figured out how to make it work, so I figured I'd share...

For me, I assumed that the scheduled task was not running at all, but after getting frustrated and taking some time off of the issue, I noticed the task had run an hour later than expected. I changed the time of the task keeping in mind this hour difference. The task ran exactly as planned. Seems to be some bug that has not been addressed yet. See these for more info: https://www.google.com/search?q=GPP+dst+bug

http://www.windows-server-answers.com/microsoft/Windows-Group-Policy/33414557/scheduled-task-pref-setting-dst-bug.aspx

share|improve this answer
add comment

User policies must be applied to an OU with user accounts in it, not computer accounts. GPO's cannot be applied to the default users OU however. A new OU must be created and those users moved to it.

share|improve this answer
add comment

Is is possible that you have a Computer Configuration set in a GPO somewhere that forbids users from adding their own scheduled tasks? I'm not sure that setting would keep your User based scheduled task GPO from applying, but it might be worth looking into.

In any event, as a workaround you might be able to use Group Policy Loopback Processing to apply your policy based a combination of both the User and Computer OUs.

share|improve this answer
    
Hi orange aruelius, thanks for your feedback - our GPO's are quite simple, and we don't have such a rule, but I will look into the Group Policy Loopback Processing, and check if this will do the trick for me. –  user80130 May 3 '11 at 6:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.