Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The openssh server was running normally in my vps and today it suddenly breaks. Any attempt that I connect from my PC or other places to it results in the following error:

hash mismatch
ssh_rsa_verify: signature incorrect
key_verify failed for server_host_key

And I connect from the vps to anywhere else results in the same error. However ssh localhost from the vps is okay.

I tried rm -rf /etc/ssh/* and re-install openssh-server, but that didn't help.

The os is ubuntu 10.04 and all packages are up to date. Could you help me with the strange error?

share|improve this question
    
so, what was the underlying problem? seems like you've solved it, since there's an accepted answer –  Paul Feb 12 '13 at 23:48
    
No, it seems to be my VPS provider's fault, and he reset the whole VPS before I could make further tests =( –  Felix Yan Feb 13 '13 at 15:39

1 Answer 1

up vote 1 down vote accepted

Try ssh -v or ssh -v -v or even ssh -v -v -v (Each increases verbosity mode). With this "debugging mode" maybe it will be easier to get a handle on the problem.

This will then give you more information so that you can actually locate the problem and fix it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.