Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have serious problems getting VLANS working on a Hyper-V host with an Intel network card.

The hardware:

  • A router / switch (linux software bridge) which is a Mikrotik 1100 AH, Router OS 5.1

  • A hyper-V server with a 4 port intel NIX

  • On the nic there are 1-4 active ports (when down to one to test) in a VMLB team using VMQ (but also tested without). This team is attached to a Hyper-V network, only (i.e. no management access).

So far:

  • The network was used for all kinds of traffic without separation. This is a "setup" phase thing. We now need to move the traffic into different VLANS to isolate the virtual machine groups.

  • The network works fine without VLAN. According to http://www.intel.com/support/network/sb/CS-030993.htm VMQ activation should automatically activate VLAN support on the virtual switch. Am I missing something?

  • The network setup is: Connection type: External. Allow Management OS is turned off.

  • Again, the whole thing works nice WITHOUT VLAN.

  • I now take one VM (a secondary DNS, external network card) and in the synthetic network adapter I turn on "enable virtual LAN identification" and add the VLAN id there (998).

  • I add a VLAN NIC to the bridge group on the switch, identified with tag 998 and add the IP address to that.

  • finally, i turn off all NIC connections to the hyper-v server sans 1 (so I know exactly which port will be used)

  • I torch (packet log) the ethernet interface. I see some VLAN 998 traffic passing from the ethernet port on the mikrotik router. Namely ethernet 800 (ip) and 806 (arp). I take that the VLAN is thus properly working on the router.

Here comes the clue: there is no traffic seemingly arriving on the virtual machine. The data seems just to be thrown away. That said, arp -a shows the mac address of the other end, so SOME stuff seems to go through.

Anyone an idea? The moment I remove the VLAN again things "just tick".

share|improve this question
    
I'm not sure where you're seeing "VMQ activation should automatically activate VLAN support on the virtual switch". –  gravyface May 2 '11 at 23:50
    
Well, in the link I did show there is no step for activating VLAN pass through at all. On top - I simply dont find any switch to turn that on. If you can point me to documentation for that and it works.... there is the answer. –  TomTom May 3 '11 at 4:36
add comment

1 Answer 1

up vote 1 down vote accepted

Even if VMQ is enabling automatically, you still need to enable VLAN trunking on the Intel nic.

On our Hyper-V setup, they default access types, and additional vlan tagged traffic gets dropped. The team that is setup as trunk ports and trunk to the switch can accept VLAN traffic and it does get routed to the VM using the setup you have above.

share|improve this answer
    
Ok, good - how do I do that? Not joking here, I do simply not see any option for that. What is the process to do so? UI or command line. –  TomTom May 5 '11 at 19:49
    
One of our Intel Nics has it under the drive configuration -> advanced options -> priority and vlan. Other was enabled during the team setup. –  Ryaner May 5 '11 at 20:31
    
Interesting. I have only one card now with 4 ports in a team.... option is ivisible nowhere. I will play with the ports tomorrow and set this. –  TomTom May 5 '11 at 21:06
    
Make sure you install the Intel drivers. The default ones from Microsoft don't include VLAN tagging as a config option. –  Brent Ozar Aug 13 '11 at 22:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.