Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having some issues getting autofs to work properly on a new Centos 5.5 installation. Please find Exports from my storage servers:

/san/files  *(rw,sync,no_subtree_check,no_root_squash)
/san/mail   *(rw,sync,no_subtree_check,no_root_squash)

On my client my auto.master looks as follows:

/home   /etc/auto.home --timeout=60
/net    -hosts

auto.home:

vmail -fstype=nfs,hard,intr,nodev,nosuid,rw xxx.xxx.xxx.xxx:/san/mail

I'm not wanting to use NIS however my bigger picture is to have a fall over nfs server however at the present time im just working with the single server.

I can manually mount the nfs share perfectly fine using "mount -t nfs xx.xxx.xxx.xxx:/san/mail /home/vmail" (when mountpoint exists Obv)

permissions on /home:

# ls -shalt /home
total 8.0K
   0 drwxr-xr-x  2 root root    0 May  3 08:51 .
8.0K drwxr-xr-x 24 root root 4.0K May  3 08:51 ..

The problem is when trying to go to /home/vmail i get the following:

# ls -shalt /home/vmail
ls: /home/vmail: No such file or directory

running "automount -vf" I get the following output:

Starting automounter version 5.0.1-0.rc2.143.el5_5.6, master map auto.master
using kernel protocol version 5.01
mounted indirect on /home with timeout 60, freq 15 seconds
mounted indirect on /net with timeout 300, freq 75 seconds
attempting to mount entry /home/vmail
lookup(program): lookup for vmail failed
failed to mount /home/vmail

Using /net/xxx.xxx.xxx.xxx/san/mail/ works!

Please help with any pointers? I'm at a dead end now.

share|improve this question
    
Does it help to mkdir /home/vmail ? –  reinierpost May 3 '11 at 9:39
    
no my understanding of autofs should create this folder dynamically, when automount is running i am unable to create the directory. –  davidcollom May 3 '11 at 10:04
    
Oh OK. Sorry, it's been over 10 years since I worked with automount .... –  reinierpost May 12 '11 at 12:18
    
Do you have selinux enabled, BTW? SElkinux under Centos 5.x tend to be pretty strict. –  Rilindo Jul 6 '11 at 13:49

1 Answer 1

up vote 2 down vote accepted

lookup(program) means automount thinks your map is an executable, does it have the executable bit set?

lookup(file) is what you should be seeing

See http://www.squarebox.co.uk/cgi-squarebox/manServer/automount.8.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.