Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

While on the LAN I can't RDP to the server.

  • Remote access is enabled
  • Correct users are added
  • All firewalls are turned off
  • I can ping the server
  • No event errors are logged
  • When I try to connect I just get the generic Remote Desktop can't connect to the remote computer for one of these reasons:
    1) Remote access to the server is not enabled
    2) The remote computer is turned off
    3) The remote computer is not available on the network

I'm not sure what else I can do to get RDP working. Any ideas?

EDIT: Confusion between RDP and Remote Desktop Services. Just need to remote in to my server with RDP.

I'm just connecting to my server remotely I do not have Remote Desktop Services installed (Terminal Services). As I said above the firewall is off and there is no other firewall between my self and the server. There are no events in the event manager showing a failed connection. Under remote settings you have to add the users you want to allow to connect to the server remotely since the user is me I have added my self to this.

share|improve this question
    
did you verify that that terminal service is running? –  tony roth May 3 '11 at 13:30
    
The service is running. –  evolvd May 3 '11 at 13:35
    
That bit about the users clears things up then. Since the machine is a domain controller, any user that wants to RDP in to it has to be a member of the Administrators group. –  NA Slacker May 4 '11 at 12:12

3 Answers 3

Double check on the firewall. If you go in to the firewall rules area there is a button you can click to change the settings. There should be a large scroll box listing lots of different programs and should they be allowed or denied.

Find Remote Desktop Access and make sure there is a check mark there for your domain access.

share|improve this answer
    
The Windows firewall is turned off. I am able to RDP to two other servers on the same switch. –  evolvd May 3 '11 at 14:02
    
Are the machines members of a domain? –  NA Slacker May 3 '11 at 14:11
    
Well the Server I am trying to RDP to is the DC. –  evolvd May 3 '11 at 15:00
    
On the server do the event logs show anything as to why it is refusing the connection? –  NA Slacker May 3 '11 at 15:10
1  
why do you want users rdpng into your dc, if you just want admins then removed the rds role. –  tony roth May 3 '11 at 22:55

On the local machine enable the "Telnet Client" feature and then try running the command "telnet localhost 3389"

If you get a blank screen with a blinking cursor you have at least connected locally.

Press Ctrl-] to get to the telnet prompt then type quite to exit.

Next run ipconfig to get the IP address of your server and try to connect to that using the RDP client on another machine. If that works you have a possible DNS issue.

Finally try running Microsoft network monitor on both sides to see if packets are being sent/received. If they aren't being responsed to then it is most likely a firewall issue

share|improve this answer
    
I just used putty to telnet to 3389 on localhost, the connection was reused. The firewall is off on the server. –  evolvd May 3 '11 at 15:04
    
try local from the server that you can't connnect to, as in telnet localhost 3389 –  tony roth May 3 '11 at 22:53
up vote 0 down vote accepted

So I ran netstat -an |find /i "listening" and found out that 3389 was not listening. Looked up the registry setting to confirm this was not changed and sure enough it was. I changed the port back to the default since there is no reason to the port changed on this server.

share|improve this answer
    
and that fixed it correct? –  tony roth May 4 '11 at 3:09
    
also this statement is what led to the confusion "•Correct users are added" hopefully you didn't add anybody to the remote desktop users group it should be blank on a dc! –  tony roth May 4 '11 at 3:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.