Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

As soon as someone tries to connect to my network, this appears in the log:

Tue May  3 15:58:40 2011 : Error: TLS Alert read:fatal:unknown CA 
Tue May  3 15:58:40 2011 : Error:     TLS_accept:failed in SSLv3 read client certificate A 
Tue May  3 15:58:40 2011 : Error: rlm_eap: SSL error error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca
Tue May  3 15:58:40 2011 : Error: rlm_eap_tls: SSL_read failed inside of TLS (-1), TLS session fails.
Tue May  3 15:58:40 2011 : Auth: Login incorrect: [steve/<no User-Password attribute>] (from client test port 18 cli 0ceee6b55136)

After Googling a bit this seems to be a problem with certificates on the client side, correct?

I'm using FreeRadius.NET hosted on Windows 7 and I'm trying to connect to the wireless network via a Windows 7 client.

After running the application in debug mode and trying again, I get this error. Pardon the screenshot, I cannot copy text in Windows command line.

enter image description here

Am I correct in this assumption that the certificate is the cause of the error? I'm 100% sure that there is a user named steve:

//In users.conf
steve User-Password == "testing"
share|improve this question
    
"Pardon the screenshot, I cannot copy text in Windows command line." I do quite a bit of work with FreeRADIUS. You should be running this on a Unix or Linux box. It's complicated enough to debug with the help of the whole FreeRADIUS community, you don't also need to run it on a weird operating system. –  Jason Antman May 3 '11 at 23:24
add comment

1 Answer

up vote 2 down vote accepted

The server is failing on the client certificate portion of authentication. Here's a how-to from FreeRADIUS on how to set up EAP-TLS, or alternatively you can set it to not require a client cert by setting it for a different EAP mechanism in eap.conf.

share|improve this answer
    
Thank you! :) This seems to be what will solve my issue. –  Only Bolivian Here May 4 '11 at 0:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.