Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've moved to a new host provider and on my last host provider they'd configured all sub-domains that don't exist to map to my base domain.

Aka,

products.searisen.com doesn't exist, but it would call searisen.com and then my default file would handle the request for it.

My new provider has me manage the IIS myself and I'm a newb at it.

I'm using IIS Manager.

Edit: It's a shared site.

Edit: The shared site is on a Windows 2008 IIS7 server.

Thanks

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

This is for IIS6: Right click the web site in IIS Manager, select properties from the context menu, on the web site tab click that Advanced button next to the ip address field, in the Advanced Web Site Identification peoperties click the ADD button, set the ip address, port, and host header value, click OK on all properties pages until the web site properties pages are closed.

share|improve this answer
    
It's a shared site. There is no properties on right click context-menu. I've sent an email to support, hopefully they can set this for me - thanks for the reply. –  Chuck Savage May 4 '11 at 0:13
    
That doesn't make sense: if you have control over IIS Manager, you have control over your host headers. Please, try again -- if it's IIS 7x, you'll see a "Bindings..." entry in the right-click context menu for the Website. See here: technet.microsoft.com/en-us/library/cc753195(WS.10).aspx –  gravyface May 5 '11 at 0:27
    
I'm sure this is the right answer, but my host provider won't modify the host headers :( They want me to check something else, URL Rewrite module in IIS7 which I'll ask a new question about after googling around first. –  Chuck Savage May 5 '11 at 0:43
    
@gravyface There's no Bindings option on the Actions menu, there are only View Applications and View Virtual Directories. –  Chuck Savage May 5 '11 at 0:59
    
right-click on the site under Sites on the left. It's there. –  gravyface May 5 '11 at 1:07
add comment

If your DNS provider allows it, add an A record for *.searisen.com pointing at the same IP address for searisen.com

Alternately, add a CNAME record for *.searisen.com with its value set to searisen.com

~MBT

share|improve this answer
    
Yeah, turns out I have a shared IP and I can't do it. Otherwise that is the thing to do. –  Chuck Savage May 10 '11 at 8:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.