Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

when I send mail to gmail through SMTP I got a erro

550 5.7.1 http://mail.google.com/support/bin/answer.py?answer=10336

follow the link it said

'The IP you're using to send email is not authorized...'

In order to prevent spam, Gmail refuses mail when the sending IP address does not match the sending domain. To send mail from your server to Gmail, we suggest using the SMTP relay provided by your ISP. Please note that we are unable to whitelist IP addresses or otherwise make exceptions at this time.

It seams that, gmail will test my ip with MX record, (for this test, I send from localhost), but if myhost.com has 3 MX record, will google test each MX to match my ip, or is there any way to bind a domain to a ip, not bind an ip to a domain.

Update

After google, I think the most import thing is set DNS PTR.

share|improve this question

migrated from stackoverflow.com May 3 '11 at 23:12

This question came from our site for professional and enthusiast programmers.

3 Answers 3

This happens when your IP address is listed in the Spamhaus PBL. This DNSBL contains a list of known dialup/dynamic IP address ranges which should not ordinarily be sending mail via SMTP.

To fix the problem, change your mail client's outgoing mail server settings to connect to port 587 instead of port 25.

share|improve this answer

I think the problem is that you are not using SSL, which is demanded by Google.

share|improve this answer

You should use the gmail smtp server as your outgoing mail server. Then Gmail will authorize and process your email.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.