Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to install SQL Server Express 2008 R2 on Windows 2003 Server (enterprise edition).

I get the following error message:

Title: caspol.exe - Application Error

Text: The application failed to initialize properly (0x000007b), Click on OK to terminate the application.

I get the same error message both when downloading the installer and running it and when using the web platform installer.

All the pages on the internet I've found about similar problem say it's a corrupt .net installation issue - This server runs multiple .net apps and I've never had any problems with any of them.

I've uninstalled and reinstalled .net (causing a painful outage) and nothing changed.

Does anyone here has any idea what might cause this?

Update 1: additional information I forgot to include: 32bit version of Windows running in a virtual machine, no anti virus

Update 2: when running caspol.exe from the command line I get the same error

share|improve this question

2 Answers 2

Do you have any anti-virus running on the server? Is this 32 bit or 64 bit?

As you say you get same error when downloading the installer and running, do you get when performing on that same server. I believe the local security policy is affective and not allowing to do so. However you can download the .NET 3.5 SP1 from seperate machine and copy on thsi machine to install.

Then execute the following command line: Drive:\WINDOWS\Microsoft.NET\Framework\%version%\caspol.exe -m -ag 1 -url "file:////\computername\sharename*" FullTrust -exclusive on

FYI: CASPOL.EXE is the Windows internal - Code Access Security Policy tool enables users and administrators to modify security policy for the machine policy level, the user policy level, and the enterprise policy level.

share|improve this answer
    
Thank you, I've tried to run the command line and caspol.exe doesn't run at all - do you have an idea what can cause that?, I've also updated the question with the missing info –  Nir May 4 '11 at 12:43

Seen errors like this from the installer being marked as coming from another computer which causes it to be blocked from doing some things. In the file properties in file explorer check if this is the case. Use the unblock button to clear this restriction from the file.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.