Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running coovachilli 1.2.5 and want to use mac authentication. I'm using

--macauth --macreauth --macpasswd macpass

in my command line. Based on tcpdump, and on my radius log, my MAC address is being authenticated and Radius is responding with an Accept, and the appropriate reply parameters.

For some reason, when I try to go to a webpage coovachilli still redirects me to the splash screen I use for authenticating normal users. Every time I go to a new page I can see radius authenticate my MAC address, and I still get redirected to the splash screen.

When I run

chilli-query list

I see my MAC address in the "dnat" state

00-22-19-F7-7F-C0 10.192.156.2 dnat 4dc12a6a00000001 0 00-22-19-F7-7F-C0 0/0 0/0 700/0 1924/0 0 0 97%/0 92%/0 http://www.google.com/

Any ideas on what is happening? Has anyone seen this before?

share|improve this question
    
You should ask about this on CoovaChilli forum: coova.org/forum/19 –  artaxerxe May 17 '12 at 10:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.