Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have windows 7 installed and I am running VMware player with Ubuntu as the guest OS. I installed Etherpad which runs on http://localhost:9000 in the VMware player. In the VMware player itself I can connect to the site with localhost:9000. If I look up the IP of the VMware player, I get some IP address. The problem is that I neither can connect from the windows system nor directly from the VMware with the IP address.

vmware: localhost:9000 -> works vmware & windows: xxx.xxx.xxx.xxx:9000 -> does not work

I can't find a solution how to connect. It's in bridged mode.

share|improve this question
2  
Can you ping the IP address of the VM from Windows 7? –  xeon May 4 '11 at 17:18
    
yes I can ping the IP address of the VM –  alesk May 4 '11 at 17:30
    
I'm not familiar with Etherpad but is there an option in the configuration file to set what IP address it listens on? –  Scott Warren May 4 '11 at 17:31
    
In the config file there is this entry: topdomains = localhost,localhost,localhost.localdomain - I tried to connect with 127.0.0.1:9000 and this doesn't work either (on the VM) –  alesk May 4 '11 at 17:36
    
What happens if you add 127.0.0.1 in the topdomains setting? –  Scott Warren May 4 '11 at 17:43

2 Answers 2

The localhost 127.0.0.1 address really means "localhost in the VM" in this case. You can not access this address from outside the VM.

The service you want to connect to must listen on "0.0.0.0", to be connectable from Host side. Then you can use the IP address of the VM.

share|improve this answer
up vote 0 down vote accepted

The solution to my problem had nothing to do with the VM. I had to add the IP address of the VM to the topdomains entry in the etherpad config file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.