Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a website written using MVC3 where the backend is a 3rd party system written in Cobol.
The webserver should starts the Cobol runtime through an interop dll and thereafter performs a call to the relevant program.

When I run this setup from Visual Studio using IIS Express then everything works fine. When I run it using "real" IIS5 however, the site hangs on the first call to the backend.
As far as running processes go, I can see that the runtime exe file is running meaning the initial call was made and permissions seem to be ok.

I have tried setting all permissions for the user on both the involved directories and files and also on the COM service.

What else could I be missing here? Is there any additional trace I could use?

share|improve this question
    
Really IIS 5? What isolation level? Which process are you talking about, ASPNET_WP? –  TristanK May 4 '11 at 23:03
    
Yes, IIS on XP. Isolation level is 'medium' - but have tried the others too. The process is ASPNET_WP. –  user80431 May 5 '11 at 5:01

1 Answer 1

Solved it from another forum - the backend was opening a debug window (trying) which wasn't visible.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.